Putting robotics at your service™

Free shipping on orders over $200

need help - Hexapod - Phoenix instruction

Print view Share :
Previous topicNext topic

Page 1 of 2 [ 23 posts ]

1, 2
User avatar
Rookie ( offline )
Posts: 23
Posted: 2010-08-09 17:12 
Recently I combine a phoenix and follow the instruction at http://www.lynxmotion.com/images/html/build159.htm

But I couldn't get it to work after I adjust and trim legs position and stuck in connect PS2 joystick, Microbasic chip & bot board all together.

Also notice the jumper cofused me as well, not sure where should I place them or not.

I only hear the tick sound. Something suspicious when wiring PS2 joystick cable. The color look different as shown on instruction. Perhaps I need to re plug those wire as shown or leave as is?

Please help me out. Thanks!


User avatar
Expert ( offline )
Posts: 746
Posted: 2010-08-09 17:17 
hardmouse wrote:
Something suspicious when wiring PS2 joystick cable. The color look different as shown on instruction. Perhaps I need to re plug those wire as shown or leave as is?

The colors of the PS2 cable wires have changed with almost every batch. If your cable does not match the current diagram, you can see a table with the different batch colors listed in the Bot Board 2 manual here:
http://www.lynxmotion.com/images/html/b ... tm#aglance

_________________
Beth
Lynxmotion, Inc
http://www.lynxmotion.com

THANKS I COULD HELP BRO


User avatar
Expert ( offline )
Posts: 536
Posted: 2010-08-09 17:52 
Have you programmed the BAP28 yet? It sounds like you're describing the default program the chip is shipped with. Take a look at steps 15 and 16 of the tutorial.

_________________
Curiously enough, the only thing that went through the mind
of the bowl of petunias as it fell was "Oh no, not again."

James "Don't call me Jim" Frye
Lynxmotion, Inc
http://www.lynxmotion.com


User avatar
Rookie ( offline )
Posts: 23
Posted: 2010-08-10 02:53 
Here is how I connect them, not too sure which jumper missing or mistaken on any connection:



I notice the PS2 wire that black/white wire are in the same pin. Does it matter?

Thanks you guys for all the helps!


User avatar
Guru ( offline )
Posts: 9257
Posted: 2010-08-10 09:51 
You have the power plug for the PS2 cable plugged in backwards.

Here is the diagram in that tutorial.



Your cable is slightly different. The red is 5vdc the black is ground just like the image, but there is a white wire with the black one.

_________________
Jim Frye, the Robot Guy
http://www.lynxmotion.com
I've always tried to do my best...


User avatar
Rookie ( offline )
Posts: 23
Posted: 2010-08-10 11:19 
Hum... I see. So color can't be trusted~ Thanks guys I will try it tonight.



User avatar
Guru ( offline )
Posts: 9257
Posted: 2010-08-10 12:21 
hardmouse wrote:
Hum... I see. So color can't be trusted~ Thanks guys I will try it tonight.


Ok we have a game plan. We will edit every tutorial that uses the PS2 and ensure the diagram accurately reflects the cable we are currently shipping. We will then make sure the words, "Please use ONLY the diagrams for wiring the PS2 controller cable. Do not use the photographs for this!" appears in each one. We will also mention in the tutorial that wiring diagrams for older cables are in the Bot Board II manual (online)

How's that?

_________________
Jim Frye, the Robot Guy
http://www.lynxmotion.com
I've always tried to do my best...


User avatar
Rookie ( offline )
Posts: 23
Posted: 2010-08-10 14:28 
Sounds cool to me(the guy with no e-background)~

Thanks!!


User avatar
Rookie ( offline )
Posts: 23
Posted: 2010-08-10 20:48 
I am not too sure but I think the problem maybe somewhere how I connect ssc32/bot board II as following. or maybe the jumper I misplaced?



User avatar
Guru ( offline )
Posts: 9257
Posted: 2010-08-11 10:09 
You have been asked if you have programmed the Atom chip, but you never responded.

You need to go into more detail as to what the problem is. What works, what does not work...

Please read this...

viewtopic.php?f=32&t=6286

_________________
Jim Frye, the Robot Guy
http://www.lynxmotion.com
I've always tried to do my best...


User avatar
Rookie ( offline )
Posts: 23
Posted: 2010-08-11 16:16 
I was in step 16 and unzip all three files to program ATOM.
The step 16 says:
"If all is well, you will hear a beep after power up. Press Start and the legs should snap to position. At this point, if you properly calibrated the servo offsets, the legs should be perfectly aligned."
&
" If you hear a continuous beeping, the PS2 controller is not connected to the Atom properly or is not functioning. If you hear beeping, you can try pressing Reset on the Bot Board II. You can also test the controller with a Playstation 2 to verify that it is working."

PS2 joystick connected, SSC32 and BB2 connected but I only hear the ticking sound and servos are not moving or aligned. That's why I wrote you an email and you ask me to post on forum here for any questions.

I 100% understand how sick to answering "not working" issue and sorry to keep asking probably "stupid" questions. Any where else I should search for answers for beginner or you could still give me a hand?


User avatar
Guru ( offline )
Posts: 9257
Posted: 2010-08-11 16:36 
The Atom chip has a program on it. It cycles the I/O pins on and off. It makes a clicking sound on the Bot Board.

The Atom is not programmed with the Phoenix code. You must program the Atom yourself. Did you program the Atom chip? Please answer yes or no. ;)

Do you have an old play station 2 game console? You can test the PS2 controller with it.

_________________
Jim Frye, the Robot Guy
http://www.lynxmotion.com
I've always tried to do my best...


User avatar
Rookie ( offline )
Posts: 23
Posted: 2010-08-11 17:15 
No. I only unzip the file(phoe2ps2.zip) in their proper place.

The PS2 joystick I test on other robots and they are working fine.


User avatar
Expert ( offline )
Posts: 536
Posted: 2010-08-11 17:25 
Um. You're going to have to actually program the robot if you expect it to actually do something... Look at steps 15 and 16 of the tutorial.

_________________
Curiously enough, the only thing that went through the mind
of the bowl of petunias as it fell was "Oh no, not again."

James "Don't call me Jim" Frye
Lynxmotion, Inc
http://www.lynxmotion.com


User avatar
Rookie ( offline )
Posts: 23
Posted: 2010-08-11 17:43 
Thanks! Jim & Fish~

I will try that in next couple of days before I pop next question :p


1, 2

All times are UTC - 5 hours [ DST ]. It is currently 2014-10-22 02:23
Feedback Form
Feedback Form