Putting robotics at your service™

Free shipping on orders over $200

Roomba 400 Series doesn't respond when buttons pushed

Print view Share :
Previous topicNext topic

Page 1 of 1 [ 6 posts ]

New ( offline )
Posts: 2
Posted: 2010-12-03 12:37 
I have a Roomba 400 Series that I am having a bit of problems with. It has a series of issues and I am going to see if I can repair them myself so I'm looking for anyone who could help me with parts that I may need so I can order them. Ok here goes.
1. It doesn't charge as well as it used to. The battery holds a charge just fine but when I put it on the docking station it has a hard time making the connection. I'v tried cleaning both the station and roomba to make it better but it still has a hard time matching up and I have to make sure that it is sitting on the stand just right.
2. Only the power button the on the top of the machine works anymore. The Clean button was the first to stop working. The machine turns on just find and none of the lights seem to be doing anything funny and I'm not getting any beeps. I push the clean button and nothing. I was then using the Max button instead of the clean button and after about 2 months of use this way the max button just stopped work along with the spot button.
3. After all of the buttons on the top of the machine stopped working I started using the remote control to start it and stop it. I had never used the remote control before so I set the scheduler remotes date and time and then set it to go. The roomba worked fine and cleaned the floor. When I went to set it the next day I had to reset the remote again and I then couldn't turn off the remote. I went on with resetting the remote and turning it off by taking the batteries out for about 2 days and the roomba worked fine. I went to start it today and nothing again. I set the remote up and pushed the clean button but the roomba won't turn on. It don't think it is receiving the signal anymore.

Can anyone help I would really like to buy the parts to repair it and keep it.

Thanks


User avatar
Veteran ( offline )
Posts: 103
Posted: 2010-12-03 16:02 
hi holly,

Welcome to the RobotShop Forum!

1. If you've cleaned the terminals on the Roomba and on the home base, then that is good. Can you tell if the home base's terminals are stuck in for any reason? They are spring loaded to accomodate the Roomba, but sometimes, if they get dirty or damaged, they can get stuck pressed down and may make poor contact. Also, after having cleaned the contacts on the home base and Roomba, do you notice if they are scratched and/or pitted? This may also contribute to the problem.

If there is nothing physically wrong with the setup, then it is likely either a defective motherboard, or a defective home base. Can you test the home base's output voltage? It should have 4.5VDC approximately.

2. It sounds like your control panel is defective. If you're okay with opening up the robot, we'd recommend you open it and remove the control panel from the top cover to clean it first. See the Ultimate Roomba Resource Center for repair manuals that will explain how to disassemble the Roomba (it doesn't show specifically how to replace the control panel, but it shows how to remove the top cover which houses the cotrol panel, and getting to the control panel is easy once you get that far). Otherwise, you may need a new control panel. Please let us know exactly what model of Roomba 400 series your have so we can confirm if we have that particular type of control panel. We may have a few other options available.

3. The Discovery series scheduling remote never turns off if the batteries are installed; this is normal and is not a cause for concern. When you say you had to reset the remote, what was happening? Was the remote losing it's program, or were you just trying to get it to turn off? Normally as long as the batteries are left inside the remote, the programs should be saved. It's a good idea to leave the batteries in the remote until they need changing.

The last time you inserted the batteries into your remote and the Roomba wouldn't turn on, did you notice anything strange with the remote, or was it bahaving properly? Try making sure the 'window' on the front of the remote (small rectangle of transparent black plastic) and the cylindrical sensor on top of the Roomba's bumper are both clean and free of any buildup or debris.

Let us know what you find out or if you have more details. It's rare we see defective remotes.

For robots that have several things wrong with them, the cost and time required to fix them can start to rise quickly. You do have the option to trade-in your defective Roomba and get a 40$ credit applicable towards a new robot purchase. It could be used for a Roomba, or any of the other robotic vacuums we carry.

Thanks,


New ( offline )
Posts: 2
Posted: 2010-12-03 17:16 
Thanks,

I'm going to try taking it apart and seeing if I can clean it out. If that doesn't help I will get back to you. The remote is a scheduler remote. Every time I go to use the remote the display says I have to reset the date. I thought that the power button on the top was supposed to turn it off. I was able to turn it on and off in the past using this button. I think.


New ( offline )
Posts: 2
Posted: 2012-01-02 12:03 
I think I need a new control panel.
My robot does not respond when I push the buttons.
It started getting difficult to get it to turn on when pressing the power button about a month ago and now it will not turn on at all.
I'm very comfortable taking the robot apart and putting it back together. I looked on the control panel and there did not appear to be any dirt between the external power button and the switch on the control panel.
So I guess I need a new control panel but I don't know the part number.
My robot is a Roomba model 4260. If you have a replacemet part for this unit please let me know.
Thanks,
Roger


New ( offline )
Posts: 2
Posted: 2012-01-02 14:37 
HI,
Just a quick update. I did some more cleaning and now every thing works fine.


User avatar
Veteran ( offline )
Posts: 103
Posted: 2012-01-03 13:33 
Sounds good, glad to hear it. Sometimes the control panel can get dirty underneath the outer panel, and this will cause problems. Cleaning often does wonders, even on old beat-up vacuum robots.


 

All times are UTC - 5 hours [ DST ]. It is currently 2014-10-21 15:57
Feedback Form
Feedback Form