Putting robotics at your service™

Free shipping on orders over $75

ssc 32 serial servie

Print view Share :
Previous topicNext topic

Page 1 of 1 [ 4 posts ]

Rookie ( offline )
Posts: 11
Posted: 2011-07-10 04:04 
 Post subject: ssc 32 serial servie
Respected sir/member

i am having ssc 32 controller board with attached to com 1 of my pc , how i can command to it like a string "#0 P1500 S750"

i have tried serial service to use this , but i was not suceesful may be i am doing something wrong , it is written in read me in the serial service we have to setup a protocol , i suppose that mean we need to change port no. and baud rate in configure.xm i ahve also done that but it is not working , i have also read magzine article on this: http://msdn.microsoft.com/en-us/magazine/ee309885.aspx

but still i am not able to conclude anything plz help me , can i use lynxmotion.ssc32 service directly with data activity with a string on it?

any help will be greatly apprecialtated

New ( offline )
Posts: 6
Posted: 2011-07-16 01:24 
 Post subject: Re: ssc 32 serial servie
Yes, I Have the same problem, I'm using BASCOMAVR and I cannot make the servo move.

Rookie ( offline )
Posts: 11
Posted: 2011-07-16 01:28 
 Post subject: Re: ssc 32 serial servie
looks like developer studio is just a toll to work with simulink, when i posted the same doubt in devedloper studio forum trevor replied use ssc-32 service when that also not working he replied use serial service even that is not working even looks like i have configured everything properly,, but now i have made my program in visual studio C#

User avatar
Guru ( offline )
Posts: 4937
Posted: 2011-07-16 10:25 
 Post subject: Re: ssc 32 serial servie
In all cases like this it would help if we could eliminate as many issues as possible to help localize the problem down. For example have you tried running the simple terminal program Lynxterm (http://www.lynxmotion.com/images/files/ ... trm111.zip). If you can enter your string in here that would imply that the SSC-32 is properly configured and you have a comm port that works...

Assuming you have been able to get the above to work, then when you run your program, what is the LED on the SSC-32 doing? If you see it blinking it is receiving some data. May not be right baud rate... But if it the LED just sits there on or off then the problem is probably actually talking to the comm port. If it is flashing but not doing anything, then it might be something as simple as you are not outputting a CR at the end of the command. Without the CR the SSC-32 will not act. It could also be that the software is configured for a different baud rate than the SSC-32 is set for.

Good Luck


All times are UTC - 5 hours [ DST ]. It is currently 2015-09-04 10:27
Feedback Form