Roomba 770 will not power on - RobotShop Forum

Putting robotics at your service™

Free shipping on orders over $75

Roomba 770 will not power on

Print view Share :
Previous topicNext topic

Page 1 of 1 [ 3 posts ]

New ( offline )
Posts: 2
Posted: 2018-04-07 16:20 
I have a Roomba 770 that I just replaced the left wheel on. When I reassembled it and tried to turn it on I get nothing. As if there is no power from the battery. I have 2 batteries. 1 is brand new. Both are fully charged.

When I connect the charger the Roomba will turn on, but as soon as power is removed it will die and will only turn back on when it is connected directly to the power source. I've tried resetting it, but no luck. I've also taken my multimeter to the battery prongs of the Roomba as soon as I remove the battery and show around d 1.5V that slowly drains.

Seems weird I have this issue after changing a wheel module... Could the wheel module ha e a short that would cause it not to power on via the battery?


User avatar
Veteran ( offline )
Posts: 157
Posted: 2018-04-09 14:29 
Hi @KWORKES,
At that point, I will suggest you verify the motherboard.
Did you buy the Roomba at RobotSHop?

_________________
Josué Michaud

RobotShop inc.
Putting Robotics at your service!™
www.robotshop.com


New ( offline )
Posts: 2
Posted: 2018-04-09 14:37 
Where would I start in verifying the motherboard?

I can find alot of info on the 5XX series, but nother for the 7XX series. They seem to be quite different.
I did real something about resistor R138 going bad. I checked the resistance on R138 and it was 104 ohms..what I read said it should be 1 ohm. I'm hesitant to short or replace this resistor for the fact the 770 motherboard is so different.


 

All times are UTC - 5 hours [ DST ]. It is currently 2018-04-26 11:12