Let's Make Robots! | RobotShop

RC Robot Car wheels turn too slowly

I have just put together a basic rc robot car, based on an arduino uno, motor shield (as I fried the original circuit board trying to measure voltages :) and of course a basic rc car (new bright). I can get the car to turn its wheels left and right and get the wheels to go forwards and backwards (when in the air) however the forwards and backward wheel speed is lacklustre (analogwrite(11, 255)- to the point where if place it on then ground the wheels don't turn and the car doesn't move. If I connect the rear wheels to the battery directly (9v battery) the wheels turn ok. It seems I don't understand the wiring or something :) I have seen a post about this before somewhere but have not been able to find it - any suggestions? Also I am currently using a 9v battery for the project but the car comes with a rechargeable 12.8v battery. I have read somewhere on the arduino site that 12v is the maximum so the question is how can I draw form this battery without frying something? (or maybe 0.8v is nothing to worry about?). ... I have read about voltage dividers is this the kind of circuit I should use? Many Thanks

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

That's your problem right there, my friend. A 9v battery can not output the current needed to run your motors. Switch to a proper battery pack of rechargeable AA or AAA batteries and you will be all set.